Sony quality control problems

Specifically for the discussion of the A-mount DSLR range
Forum rules
No more than three images or three external links allowed in any post or reply. Please trim quotations and do not include images in quotes unless essential.
User avatar
mvanrheenen
Emperor of a Minor Galaxy
Posts: 1708
Joined: Mon Nov 29, 2010 3:58 pm
Location: Netherlands
Contact:

Re: Sony quality control problems

Unread postby mvanrheenen » Thu Mar 08, 2012 11:01 am

pakodominguez wrote:This are two different problems. The NEX3/NEX5 glass get a sort of chemical reaction over the time. I need to replace mine also and I'm not sure if I'll send it to Sony or if I'll do it myself.

The Dyxum guy just peel off the original protection on its screen when he tried to replace his "protection"


Pako, do you mean this issue?

Image

User avatar
pakodominguez
Minister with Portfolio
Posts: 2537
Joined: Tue May 22, 2007 5:38 pm
Location: NYC
Contact:

Re: Sony quality control problems

Unread postby pakodominguez » Thu Mar 08, 2012 1:36 pm

mvanrheenen wrote:
pakodominguez wrote:This are two different problems. The NEX3/NEX5 glass get a sort of chemical reaction over the time. I need to replace mine also and I'm not sure if I'll send it to Sony or if I'll do it myself.

The Dyxum guy just peel off the original protection on its screen when he tried to replace his "protection"


Pako, do you mean this issue?

Image

Yes
Pako
------------
http://www.pakodominguez.photo/blog" onclick="window.open(this.href);return false;

User avatar
mvanrheenen
Emperor of a Minor Galaxy
Posts: 1708
Joined: Mon Nov 29, 2010 3:58 pm
Location: Netherlands
Contact:

Re: Sony quality control problems

Unread postby mvanrheenen » Thu Mar 08, 2012 1:49 pm

Cr*p :(

Don't have any kind of guarantee on this camera :( Any idea what it would cost if I let Sony repair it?

Mark

User avatar
Birma
Tower of Babel
Posts: 6679
Joined: Sun Jun 29, 2008 3:10 pm

Re: Sony quality control problems

Unread postby Birma » Thu Mar 08, 2012 3:03 pm

Apologies if it has already been linked to, but have you seen DK's repair description here http://www.photoclubalpha.com/2011/04/18/replacing-nex-lcd-cover-glass/?The result looks very good to me.

My Nex 5 screen still looks fine but it is much newer - bought in August 2011, but used quite heavily since then. I've had a GGS screen on it 95% of the time, and a sun shield with magnifier the rest.
Nex 5, Nex 6 (IR), A7M2, A99 and a bunch of lenses.

User avatar
Greg Beetham
Tower of Babel
Posts: 6155
Joined: Sun May 27, 2007 3:25 pm
Location: Townsville, Qld. Australia
Contact:

Re: Sony quality control problems

Unread postby Greg Beetham » Sat Mar 10, 2012 2:18 am

I wonder if this has been fixed in the NEX7? Being able to build screens that don't delaminate isn't exactly covering new ground.
Greg

User avatar
mvanrheenen
Emperor of a Minor Galaxy
Posts: 1708
Joined: Mon Nov 29, 2010 3:58 pm
Location: Netherlands
Contact:

Re: Sony quality control problems

Unread postby mvanrheenen » Sat Mar 10, 2012 11:34 am

Thanks for the link Birma, didn't see it before. I'll have a look at it!

Mark

User avatar
mvanrheenen
Emperor of a Minor Galaxy
Posts: 1708
Joined: Mon Nov 29, 2010 3:58 pm
Location: Netherlands
Contact:

Re: Sony quality control problems

Unread postby mvanrheenen » Sat Mar 10, 2012 11:49 am

mvanrheenen wrote:Thanks for the link Birma, didn't see it before. I'll have a look at it!

Mark


Well, it worked, except there is a lot of glue still on the screen :-( I'll get some electronics cleaner from the office to remove it. Thanks for the tip!

Mark

User avatar
Winston
Imperial Ambassador
Posts: 481
Joined: Fri Jul 18, 2008 5:29 pm
Location: Boise, Idaho, USA, 3rd Planet

Re: Sony quality control problems

Unread postby Winston » Sat Mar 10, 2012 11:47 pm

Other than some ID-10-t errors, I have had no problems with my A77.
Expectations surpassed so far...only a few hundred clicks and some video.
Winston Mitchell
KM7D, A700, A77, A77M2

User avatar
Dr. Harout
Tower of Babel
Posts: 5833
Joined: Wed May 30, 2007 7:38 pm
Location: Yerevan, Armenia
Contact:

Re: Sony quality control problems

Unread postby Dr. Harout » Sun Mar 11, 2012 12:22 am

Winston wrote:Other than some ID-10-t errors, I have had no problems with my A77.
Expectations surpassed so far...only a few hundred clicks and some video.

:lol: :lol:
Seriously, what are your thoughts on the a77?
A99 + a7rII + Sony, Zeiss, Minolta, Rokinon and M42 lenses

Flickr

User avatar
mvanrheenen
Emperor of a Minor Galaxy
Posts: 1708
Joined: Mon Nov 29, 2010 3:58 pm
Location: Netherlands
Contact:

Re: Sony quality control problems

Unread postby mvanrheenen » Mon Mar 12, 2012 3:32 pm

Well, I finally sent my a580 to the retailer I bought it for the control wheel problem. I'm very anxious to hear what they have to say about it.

Mark

User avatar
mvanrheenen
Emperor of a Minor Galaxy
Posts: 1708
Joined: Mon Nov 29, 2010 3:58 pm
Location: Netherlands
Contact:

Re: Sony quality control problems

Unread postby mvanrheenen » Tue Apr 10, 2012 8:59 am

So, after about 4 weeks my retailer returned the a580. They have replaced the 'top assembly' of the camera to correct the control wheel problem. I shot over 400 images this weekend and the control wheel seems fine now. Everything was repaired under warranty.

User avatar
bakubo
Subsuming Vortex of Brilliance
Posts: 5632
Joined: Tue Nov 06, 2007 7:55 am
Location: Hawaii
Contact:

Re: Sony quality control problems

Unread postby bakubo » Tue Apr 10, 2012 10:23 am

mvanrheenen wrote:So, after about 4 weeks my retailer returned the a580. They have replaced the 'top assembly' of the camera to correct the control wheel problem. I shot over 400 images this weekend and the control wheel seems fine now. Everything was repaired under warranty.


Good luck. I hope the problem is really fixed. You can see the list of parts Sony replaced in my A700 to "fix" the problem in 2009:

viewtopic.php?f=32&t=2610

I thought they really fixed it, but after about 2 months or so the problem returned just like it was before.

User avatar
mvanrheenen
Emperor of a Minor Galaxy
Posts: 1708
Joined: Mon Nov 29, 2010 3:58 pm
Location: Netherlands
Contact:

Re: Sony quality control problems

Unread postby mvanrheenen » Tue Apr 10, 2012 12:16 pm

Hi Henry,

I have a more detailed list of parts they replaced and even errors they've encountered. Will list them later this week.

Indeed I hope the problems will be fixed. If not, I'll repeat the same proces. That would be a real bummer though.

Mark

User avatar
Winston
Imperial Ambassador
Posts: 481
Joined: Fri Jul 18, 2008 5:29 pm
Location: Boise, Idaho, USA, 3rd Planet

Re: Sony quality control problems

Unread postby Winston » Wed Apr 11, 2012 8:16 pm

Dr. Harout wrote:
Winston wrote:Other than some ID-10-t errors, I have had no problems with my A77.
Expectations surpassed so far...only a few hundred clicks and some video.

:lol: :lol:
Seriously, what are your thoughts on the a77?

Brief summary:

- No problems to date.
- The time it takes to format a card is a little annoying.
- I hate the tiny SD cards...always have. Can anybody recommend a good SD wallet?
- Love the viewfinder.
- A surprise for me...I really like the Display Panel.
- Because of the Display Panel and the WYSIWYG view finder, I almost never look at the rear LCD except for composition when it's more convenient than the view finder.
- Love the quiet shutter.
- Noise could be better but I wouldn't trade the next item for it.
- Love the 40% reach increase for wildlife photography. The 70-400G is good enough to make it all usable.

For me it has required the effort to learn how to use a fundamentally different tool. It is not just an upgrade to the A700; for the patient, it is much more.
Winston Mitchell
KM7D, A700, A77, A77M2


Return to “Alpha A-mount System”

Who is online

Users browsing this forum: No registered users and 10 guests