From RAW conversion to image editing and printing
User avatar
Posts: 4
Joined: Sat Aug 04, 2007 2:43 pm
Location: Bristol


Unread postby wobble » Thu Aug 16, 2007 12:11 am

I've got PS CS3 (Extended) and I've being trying to install it on our new laptop without success. The laptop spec - a Dell Centrino Duo running Vista Premium with Elements 5 already installed.

I tried loading both standalone and connected to the net. It will only install: Bridge, Device Central, Help Center and Help Viewer, Stock Photos, Utilities and Extend Scrip Toolkit.

I've loaded it now onto our older desktop machine and it worked. The desktop spec - Athlon 64 3200+ running XP Home (SP2) with Elements 4 already installed.

I've tried some registry hacks that people have mentioned without success. It may just be one of those hardware/software issues affecting Vista at the moment. It's not the end of the world as I can still use it on the desktop.

Any thoughts or ideas though would be appreciated.

David Kilpatrick
Site Admin
Posts: 6248
Joined: Sat May 19, 2007 1:14 pm
Location: Kelso, Scotland

Unread postby David Kilpatrick » Thu Aug 16, 2007 1:26 am

No idea why it would not install. You should be able to install almost on any machine, it is activation which is the issue (only two machines allowed).

All you are getting is the Bridge module. I would suggest running a deinstallation on Elements 5 first (not a manual removal) and, if you have for any reason previously installed a trial or beta copy of CS3, you MUST run a deinstall on that and clean out ALL files associated with it. This is a big problem. I ended up buying a new machine to install CS3 on Mac, the trial version has totally screwed up my previous one for a reliable installation, without wiping the HD.


Return to “Digital Workflow and PP”

Who is online

Users browsing this forum: No registered users and 2 guests