SLT A57 question

Specifically for the discussion of the current Sony Alpha DSLR range and its expansion
Forum rules
No more than three images or three external links allowed in any post or reply. Please trim quotations and do not include images in quotes unless essential.
chriznatch
Initiate
Posts: 34
Joined: Thu Jun 12, 2008 7:26 pm

SLT A57 question

Unread postby chriznatch » Sat Dec 08, 2012 12:06 am

I have a new A57, and I'm trying to get the hang of the controls. One issue is that I can't figure out how to change aperture in manual exposure mode. Gary Friedman's book says to hold the exposure compensation button and move the front control dial to change aperture. But when I press the exposure compensation button in M mode, it says "Unavailable in this shooting mode. Available in P/A/S modes." It won't change the aperture. Has anyone run into this issue? Is there some other way to change the aperture? Thanks in advance.

chriznatch
Initiate
Posts: 34
Joined: Thu Jun 12, 2008 7:26 pm

Re: SLT A57 question

Unread postby chriznatch » Sat Dec 08, 2012 12:16 am

Never mind, I just figured it out. You change aperture in M mode by pressing the AEL button and rotating the front control dial.

User avatar
David Kilpatrick
Site Admin
Posts: 6214
Joined: Sat May 19, 2007 1:14 pm
Location: Kelso, Scotland
Contact:

Re: SLT A57 question

Unread postby David Kilpatrick » Sat Dec 08, 2012 3:13 am

Solved before anyone had time to notice!

Headcell
Heirophant
Posts: 67
Joined: Sat May 29, 2010 4:29 pm

Re: SLT A57 question

Unread postby Headcell » Sat Dec 08, 2012 10:15 am

The A57 is magnificent camera. I find it generally takes superb pictured even when in Auto mode. The 12fps shooting is incredible.

But the esoteric error messages - terrible!

User avatar
bfitzgerald
Subsuming Vortex of Brilliance
Posts: 3388
Joined: Fri Sep 26, 2008 10:48 pm

Re: SLT A57 question

Unread postby bfitzgerald » Sat Dec 08, 2012 6:50 pm

You mean the annoying "nag" screens that turn up when you press a button that doesn't do anything?
Yes they are a pain in the rear end I wish Sony would cut out this hand holding nonsense.

That "clear image zoom" button and the ? one are a huge waste for what could be really useful buttons. Move the AEL to the zoom button, move the exp comp to the AEL place..and dump the stupid zoom button which does nothing in raw anyway! Apart from that it's not bad at all really

agorabasta
Viceroy
Posts: 1198
Joined: Wed Oct 22, 2008 7:41 pm

Re: SLT A57 question

Unread postby agorabasta » Sat Dec 08, 2012 8:50 pm

And now we've just got a new 'error message' fresh off the recent FW update.
Now trying to finish some long chain of button-pressing and menu-scrolling with one hand and at that accidentally pushing the 'disabled' video button, you get that brand new 'error message'; and all the long chain of push/scroll is gone.
So instead of disabling that stinky video button, they assigned another disastrous function to that...

User avatar
bfitzgerald
Subsuming Vortex of Brilliance
Posts: 3388
Joined: Fri Sep 26, 2008 10:48 pm

Re: SLT A57 question

Unread postby bfitzgerald » Sun Dec 09, 2012 12:20 pm

I had it pre latest firmware and noted that the disable video button arrived with the latest firmware update. If you disable it and you are not in video mode you get a nice message
"Invalid in this mode available in movie mode"
Would be much better if you could map the movie button to actually do something in stills shooting. So that's 2 buttons on the top back of the camera that are mostly useless (other being the zoom button) If Sony thought about it a bit more they would allow both buttons to be user assigned. It's just a case of not thinking things through properly or actually field testing a product properly.

Maybe they will do that with a firmware update..maybe not. I'm trying to overlook these annoyances because unlike the Nikon's I had this is actually good for autofocus!

Andy B
Heirophant
Posts: 65
Joined: Tue Feb 03, 2009 6:02 am
Location: Kalamazoo, Michigan, USA

Re: SLT A57 question

Unread postby Andy B » Mon Dec 10, 2012 2:23 am

I've read enough "clear image zoom" threads over at DPR to know that not everyone, including me, considers the zoom button a waste. However, I do agree that it would be ideal if it could be user-assigned for those who wish to do so.

Totally agree on the ? button, which on my A57 only gets pressed by accident.

The button I miss the most from my A700 (besides the handy exposure mode dial) is the C button, which I used for quick access to flash exposure compensation. I also miss the convenience of having an on-off stabilization switch.

User avatar
bfitzgerald
Subsuming Vortex of Brilliance
Posts: 3388
Joined: Fri Sep 26, 2008 10:48 pm

Re: SLT A57 question

Unread postby bfitzgerald » Mon Dec 10, 2012 11:43 am

The zoom button is only of use if you shoot jpeg, it just gives you another annoying nag screen if you are in raw. It doesn't even work for raw+jpeg either.
? only gets used for deleting shots it's one of the 3 buttons that "should" be user assigned but are not. BTW I don't have a problem with Sony putting a guide/help thing in there..but for crying out loud let it be customisable as more experienced users will never use it again. I can think of much more useful things to do with the zoom button, and the movie one and ?.

Sony could fix this stuff with a firmware update..and it's one of the reasons I disagree with DPR's "Gold award" (the other being the jpeg quality)


Return to “Sony Alpha 100-900”

Who is online

Users browsing this forum: Bing [Bot] and 0 guests